Category: Ripple (XRP)

fix1578 is Now Available

As previously announced, the fix1578 amendment became enabled on the XRP Ledger on 2019-03-23.

Action Required

  • If you operate a rippled server, you should upgrade to version 1.2.0 (or higher) immediately. Version 1.2.2 is recommended.

For instructions on upgrading rippled on supported platforms, see Install rippled.

Impact of Not Upgrading

If you operate a rippled server on a version older than 1.2.0, then your server is now amendment blocked, meaning that your server:

  • Cannot determine the validity of a ledger
  • Cannot submit or process transactions
  • Does not participate in the consensus process
  • Does not vote on future amendments
  • Could rely on potentially invalid data

fix1578 Summary

Changes the result codes returned by two transaction types:

  • Changes the OfferCreate transaction to return a new result code, tecKILLED, if the offer used the tfFillOrKill flag and was killed. Without this amendment, the offer is killed but the transaction result is tesSUCCESS.
  • Changes the TrustSet transaction to fail with tecNO_PERMISSION if it tries to enable the NoRipple flag but cannot because the trust line has a negative balance. Without this amendment, the transaction does not enable the NoRipple flag, but the transaction result is tesSUCCESS nonetheless.

Learn, ask questions, and discuss

Related documentation is available in the XRP Ledger Dev Portal, including detailed example API calls and web tools for API testing.

Other resources:

This article was originally published on: The Ripple Blog on